How to make a logo with transparent background using GIMP or Photoshop


Want to add a logo to your picture, but can’t get rid of the background? Then this guide will solve that with just a few easy steps!


Do I need special software?

You don’t. But, especially with complicated logos, it will speed up your process a lot.


I prefer to use GIMP, as it is an open source tool completely free to use and has many features Photoshop has to offer as well. If you have Photoshop, there's a guide on making a transparent background down below.


If you do not want to download external software you can find a guide on how to make your background transparent with the online editor Picmonkey right here

Now, let’s get started, shall we?


GIMP


Step 1: Setting GIMP up

Alright, so you installed GIMP and fired it up, it will probably look similar to this.


GIMP launch screen


To open GIMP in one window, you go to Windows > Single-Window Mode


GIMP how to go to Single-Window Mode


Step 2: Making the background transparent

Now open the image you want to make transparent. I’ve chosen this image:


Your Awesome Logo


But you can use whatever image you like. To open an image go to File > Open and then select your file. Alternatively, you can press CTRL + O.


How to open an image in GIMP


What differs GIMP and Photoshop from Paint and similar programs is that they use layers. Each layer can be edited individually, so you can edit parts of your image without having to touch the other one.


These layers can be found in the upper right corner of your screen. To add transparency right-click the layer and select 'Add Alpha Channel'.


GIMP add alpha channel


To make the background transparent we will use the Select By Color Tool. You can use it by pressing Shift + O or going to Tools > Selection Tools > By Color Select.


Press anywhere around the logo on the white space you want to erase. A moving dotted line should appear around it. Press delete and a checker-like background should appear, like so:


Your Awesome Logo transparent background


If this isn’t the case make sure you added an alpha channel to your image, and there aren’t any other layers left. If you have a ‘Background’ layer you can delete this by right-clicking it and selecting ‘Delete Layer’.


Congratulations! You’ve made your first logo with a transparent background!


Step 3: Exporting your logo

You can’t simply ‘Save’ your image or ‘Save As’. You will save your image in .xcf format, this way it’s only suitable for an image editor. To use it on your site you have to export your image. To do this go to File > Export As or press Shift + Ctrl + E.


You can also choose to overwrite your file, but then the original image will be lost. A menu asking you where your file should be stored will pop up. You can also change the name of your image, make sure you add .png at the end. Formats like .jpg do not support transparency while .png does.



Now press ‘Export’ and you are done!


To brand your survey with your transparent logo we’ve made a guide dedicated to that in our docs.


Now, let’s see how you can do this with Photoshop:



Photoshop

I am using Photoshop CS6 in this tutorial. The performance will stay the same whether you use an older or newer version, menus may simply look a little different.


Method 1: Magic Wand Tool


Step 1: Open the image

You do this by going to File > Open or you can press the shortcut Ctrl + O.


Open image in Photoshop


Step 2: Selecting Magic Wand Tool

You can see the icon to the right of your screen in the vertical Tools Panel. Right click the 4th icon and select the Magic Wand Tool. You can also press W as a shortcut.


Magic Wand Tool Icon Photoshop


Step 3: Removing background

Press anywhere in the background space you want to delete. A dotted line will appear indicating the area you are about to delete. If the area isn’t big enough, you can always add more to your selection by holding down Shift + clicking the area you want to add.


If you miss clicked you can remove your entire selection by right-clicking and picking Deselect.


A checker-like background should appear on your image.


Step 4: Saving your image

Now it’s time to save your image. Go to File > Save as. Not all image types display transparency. Make sure your image is saved as a PNG file.



Select the PNG option:


Save as PNG


Now press ‘Save’.


To brand your survey with your transparent logo we’ve made a guide dedicated to that in our docs.


Ta-da! You now have a transparent logo. But, there’s a second way to do this:


Method 2: Polygonal Lasso Tool


If your background is a little too cluttered the Magic Wand tool will not always be sufficient. In this case, we will use the Polygonal Lasso Tool.


Step 1: Open the image

You do this by going to File > Open or you can press the shortcut Ctrl + O.


Open image in Photoshop


Step 2: Polygonal Lasso Tool

You can see the icon to the right of your screen in the vertical Tools Panel. Right click the 3rd icon and select the Polygonal Lasso Tool. If you already selected it simply press L as a shortcut.


Select Polygonal Lasso Tool Photoshop


Step 3: Removing background

You can now draw a path around what you want to delete yours from your image. To select more accurately you can always press Ctrl and ‘+’to zoom. To complete your selection press Ctrl + click on the final piece of your created path. Press Delete to remove the element, a checker-like background should appear at the place of the object.


Step 4: Saving your image

Go to File > Save as. Make sure your image is saved as a PNG-file. Other image types do not always support transparency.


Save As menu Photoshop


Select the PNG option:


Save as PNG


Now press ‘Save’.


To brand your survey with your transparent logo we’ve made a guide dedicated to that in our docs.


Woo-hoo! Have fun gathering your data!